import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "type:: Coffee Shop\\naddress::";
final String string = "- Perk Cafe\n"
+ "type:: Coffee Shop\n"
+ "address:: 123 Main St.\n"
+ "serves_food:: Yes\n\n"
+ "- Daily Boo\n"
+ "type:: Thee Shop\n"
+ "address:: 10 Broadway\n"
+ "serves_food:: No\n\n"
+ "- Daily Joe\n"
+ "type:: Coffee Shop\n"
+ "address:: 10 Broadway\n"
+ "serves_food:: No\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}