use strict;
my $str = '- Perk Cafe
type:: Coffee Shop
address:: 123 Main St.
serves_food:: Yes
- Daily Boo
type:: Thee Shop
address:: 10 Broadway
serves_food:: No
- Daily Joe
type:: Coffee Shop
address:: 10 Broadway
serves_food:: No
';
my $regex = qr/type:: Coffee Shop\naddress::/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}