re = /type:: Coffee Shop\naddress::/m
str = '- Perk Cafe
type:: Coffee Shop
address:: 123 Main St.
serves_food:: Yes
- Daily Boo
type:: Thee Shop
address:: 10 Broadway
serves_food:: No
- Daily Joe
type:: Coffee Shop
address:: 10 Broadway
serves_food:: No
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end