const regex = /type:: Coffee Shop\naddress::/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('type:: Coffee Shop\\naddress::', 'gm')
const str = `- Perk Cafe
type:: Coffee Shop
address:: 123 Main St.
serves_food:: Yes
- Daily Boo
type:: Thee Shop
address:: 10 Broadway
serves_food:: No
- Daily Joe
type:: Coffee Shop
address:: 10 Broadway
serves_food:: No
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}