using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ref>(?:(?!<\/ref>).)*example\.com.*?<\/ref>";
string substitution = @"";
string input = @"<ref>{{cite web|title=Foo|url=https://zzz.com/foo}}</ref> blah-blah <ref>{{cite web|title=Bar|url=https://example.com/bar}}</ref> some more blah <ref>{{cite web|title=Foo|url=https://pqr.com/foo}}</ref>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}