const regex = /<ref>(?:(?!<\/ref>).)*example\.com.*?<\/ref>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<ref>(?:(?!<\\\/ref>).)*example\\.com.*?<\\\/ref>', 'gm')
const str = `<ref>{{cite web|title=Foo|url=https://zzz.com/foo}}</ref> blah-blah <ref>{{cite web|title=Bar|url=https://example.com/bar}}</ref> some more blah <ref>{{cite web|title=Foo|url=https://pqr.com/foo}}</ref>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);