import re
regex = re.compile(r"<ref>(?:(?!<\/ref>).)*example\.com.*?<\/ref>", flags=re.MULTILINE)
test_str = "<ref>{{cite web|title=Foo|url=https://zzz.com/foo}}</ref> blah-blah <ref>{{cite web|title=Bar|url=https://example.com/bar}}</ref> some more blah <ref>{{cite web|title=Foo|url=https://pqr.com/foo}}</ref>"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)