$re = '/<ref>(?:(?!<\/ref>).)*example\.com.*?<\/ref>/m';
$str = '<ref>{{cite web|title=Foo|url=https://zzz.com/foo}}</ref> blah-blah <ref>{{cite web|title=Bar|url=https://example.com/bar}}</ref> some more blah <ref>{{cite web|title=Foo|url=https://pqr.com/foo}}</ref>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;