// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(:|;){1}(\-|~)?(D|\)){1}$").unwrap();
let string = ":D
:)
;D
;)
:D
x)
:-D
:0)
;~D
;_)
:D";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}