# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z]+:)([0-9]{1,3}%) ([a-zA-Z]+)(?: ([0-9]{1,3}%) ([a-zA-Z]+))?/#$1 $2 $3, $4 $5/g;t' <<< "A:82% X 18% Y B:100% X C:82% X 18% Y AB:82% X 18% Y"