const regex = /([a-zA-Z]+:)([0-9]{1,3}%) ([a-zA-Z]+)(?: ([0-9]{1,3}%) ([a-zA-Z]+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]+:)([0-9]{1,3}%) ([a-zA-Z]+)(?: ([0-9]{1,3}%) ([a-zA-Z]+))?', 'g')
const str = `A:82% X 18% Y B:100% X C:82% X 18% Y AB:82% X 18% Y`;
const subst = `#$1 $2 $3, $4 $5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);