import re
regex = re.compile(r"([a-zA-Z]+:)([0-9]{1,3}%) ([a-zA-Z]+)(?: ([0-9]{1,3}%) ([a-zA-Z]+))?")
test_str = "A:82% X 18% Y B:100% X C:82% X 18% Y AB:82% X 18% Y"
subst = "#$1 $2 $3, $4 $5"
result = regex.sub(subst, test_str)
if result:
print(result)