import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]+:)([0-9]{1,3}%) ([a-zA-Z]+)(?: ([0-9]{1,3}%) ([a-zA-Z]+))?";
final String string = "A:82% X 18% Y B:100% X C:82% X 18% Y AB:82% X 18% Y";
final String subst = "#$1 $2 $3, $4 $5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}