#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/[\w\d\.]*(?<!(CorrectDomain1\.co\.uk))(?<!(CorrectDomain2\.com))(?<!(CorrectDomain3\.org))(\/|\"|\t|\r|\n|\s)"
Local $sString = "<a href="http://www.WrongDomainA.co.uk">Link</a>" & @CRLF & _
"<a href="http://www.WrongDomainA.co.uk/">Link</a>" & @CRLF & _
"<a href="https://www.WrongDomainA.co.uk/">Link</a>" & @CRLF & _
"http://www.WrongDomainA.co.uk" & @CRLF & _
"http://www.WrongDomainA.co.uk/" & @CRLF & _
"https://www.WrongDomainA.co.uk" & @CRLF & _
"http://www.CorrectDomain1.co.uk.WrongDomainA.co.uk/" & @CRLF & _
"http://www..WrongDomainA.co.uk/CorrectDomain1.co.uk" & @CRLF & _
"" & @CRLF & _
"<a href="http://www.CorrectDomain1.co.uk">Link</a>" & @CRLF & _
"<a href="http://www.CorrectDomain1.co.uk/">Link</a>" & @CRLF & _
"http://www.CorrectDomain1.co.uk" & @CRLF & _
"http://www.CorrectDomain1.co.uk/" & @CRLF & _
"" & @CRLF & _
"<a href="http://www.CorrectDomain2.com">Link</a>" & @CRLF & _
"<a href="http://www.CorrectDomain2.com/">Link</a>" & @CRLF & _
"http://www.CorrectDomain2.com" & @CRLF & _
"http://www.CorrectDomain2.com/" & @CRLF & _
"" & @CRLF & _
"<a href="https://CorrectDomain2.com/index.php?id=10">Link</a>" & @CRLF & _
"https://CorrectDomain2.com/index.php?id=10" & @CRLF & _
"" & @CRLF & _
"<a href="https://www.CorrectDomain3.org/link">Link</a>" & @CRLF & _
"https://www.CorrectDomain3.org/link/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")