import Foundation
let pattern = #"https?:\/\/[\w\d\.]*(?<!(CorrectDomain1\.co\.uk))(?<!(CorrectDomain2\.com))(?<!(CorrectDomain3\.org))(\/|\"|\t|\r|\n|\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a href="http://www.WrongDomainA.co.uk">Link</a>
<a href="http://www.WrongDomainA.co.uk/">Link</a>
<a href="https://www.WrongDomainA.co.uk/">Link</a>
http://www.WrongDomainA.co.uk
http://www.WrongDomainA.co.uk/
https://www.WrongDomainA.co.uk
http://www.CorrectDomain1.co.uk.WrongDomainA.co.uk/
http://www..WrongDomainA.co.uk/CorrectDomain1.co.uk
<a href="http://www.CorrectDomain1.co.uk">Link</a>
<a href="http://www.CorrectDomain1.co.uk/">Link</a>
http://www.CorrectDomain1.co.uk
http://www.CorrectDomain1.co.uk/
<a href="http://www.CorrectDomain2.com">Link</a>
<a href="http://www.CorrectDomain2.com/">Link</a>
http://www.CorrectDomain2.com
http://www.CorrectDomain2.com/
<a href="https://CorrectDomain2.com/index.php?id=10">Link</a>
https://CorrectDomain2.com/index.php?id=10
<a href="https://www.CorrectDomain3.org/link">Link</a>
https://www.CorrectDomain3.org/link/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)