use strict;
my $str = '<a href="http://www.WrongDomainA.co.uk">Link</a>
<a href="http://www.WrongDomainA.co.uk/">Link</a>
<a href="https://www.WrongDomainA.co.uk/">Link</a>
http://www.WrongDomainA.co.uk
http://www.WrongDomainA.co.uk/
https://www.WrongDomainA.co.uk
http://www.CorrectDomain1.co.uk.WrongDomainA.co.uk/
http://www..WrongDomainA.co.uk/CorrectDomain1.co.uk
<a href="http://www.CorrectDomain1.co.uk">Link</a>
<a href="http://www.CorrectDomain1.co.uk/">Link</a>
http://www.CorrectDomain1.co.uk
http://www.CorrectDomain1.co.uk/
<a href="http://www.CorrectDomain2.com">Link</a>
<a href="http://www.CorrectDomain2.com/">Link</a>
http://www.CorrectDomain2.com
http://www.CorrectDomain2.com/
<a href="https://CorrectDomain2.com/index.php?id=10">Link</a>
https://CorrectDomain2.com/index.php?id=10
<a href="https://www.CorrectDomain3.org/link">Link</a>
https://www.CorrectDomain3.org/link/
';
my $regex = qr/https?:\/\/[\w\d\.]*(?<!(CorrectDomain1\.co\.uk))(?<!(CorrectDomain2\.com))(?<!(CorrectDomain3\.org))(\/|\"|\t|\r|\n|\s)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}