const regex = /https?:\/\/[\w\d\.]*(?<!(CorrectDomain1\.co\.uk))(?<!(CorrectDomain2\.com))(?<!(CorrectDomain3\.org))(\/|\"|\t|\r|\n|\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/[\\w\\d\\.]*(?<!(CorrectDomain1\\.co\\.uk))(?<!(CorrectDomain2\\.com))(?<!(CorrectDomain3\\.org))(\\\/|\\"|\\t|\\r|\\n|\\s)', 'gm')
const str = `<a href="http://www.WrongDomainA.co.uk">Link</a>
<a href="http://www.WrongDomainA.co.uk/">Link</a>
<a href="https://www.WrongDomainA.co.uk/">Link</a>
http://www.WrongDomainA.co.uk
http://www.WrongDomainA.co.uk/
https://www.WrongDomainA.co.uk
http://www.CorrectDomain1.co.uk.WrongDomainA.co.uk/
http://www..WrongDomainA.co.uk/CorrectDomain1.co.uk
<a href="http://www.CorrectDomain1.co.uk">Link</a>
<a href="http://www.CorrectDomain1.co.uk/">Link</a>
http://www.CorrectDomain1.co.uk
http://www.CorrectDomain1.co.uk/
<a href="http://www.CorrectDomain2.com">Link</a>
<a href="http://www.CorrectDomain2.com/">Link</a>
http://www.CorrectDomain2.com
http://www.CorrectDomain2.com/
<a href="https://CorrectDomain2.com/index.php?id=10">Link</a>
https://CorrectDomain2.com/index.php?id=10
<a href="https://www.CorrectDomain3.org/link">Link</a>
https://www.CorrectDomain3.org/link/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}