#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^( +)(.*)$"
Local $sString = " sdf" & @CRLF & _
" asdasd sdf" & @CRLF & _
" ss sdf"
Local $sSubst = "<!--$1-->$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)