package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^( +)(.*)$`)
var str = ` sdf
asdasd sdf
ss sdf`
var substitution = "<!--$1-->$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}