re = /^( +)(.*)$/m
str = ' sdf
asdasd sdf
ss sdf'
subst = '<!--$1-->$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result