#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<div id=""target""((?'nested'<div)|</div(?'-nested')|[\w\W]*?)*</div>"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html>" & @CRLF & _
" <head>" & @CRLF & _
" <title>someTitle</title>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <div class="outer">" & @CRLF & _
" <h1>SomeHeader</h1>" & @CRLF & _
" <div id="target">" & @CRLF & _
" <h2>anotherHeader</h2>" & @CRLF & _
" <div id="child">" & @CRLF & _
" <div id="grand-child">" & @CRLF & _
" <h4>HelloWorld</h4>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")