package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<div id=""target""((?'nested'<div)|</div(?'-nested')|[\w\W]*?)*</div>`)
var str = `<!DOCTYPE html>
<html>
<head>
<title>someTitle</title>
</head>
<body>
<div class="outer">
<h1>SomeHeader</h1>
<div id="target">
<h2>anotherHeader</h2>
<div id="child">
<div id="grand-child">
<h4>HelloWorld</h4>
</div>
</div>
</div>
</div>
</body>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}