use strict;
my $str = '<!DOCTYPE html>
<html>
<head>
<title>someTitle</title>
</head>
<body>
<div class="outer">
<h1>SomeHeader</h1>
<div id="target">
<h2>anotherHeader</h2>
<div id="child">
<div id="grand-child">
<h4>HelloWorld</h4>
</div>
</div>
</div>
</div>
</body>
</html>';
my $regex = qr/<div id=""target""((?'nested'<div)|</div(?'-nested')|[\w\W]*?)*</div>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}