#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((\/(index(\..+)?)?)|(\..{2,4}))$"
Local $sString = "/foo/bar/index.php" & @CRLF & _
"/foo/bar/index" & @CRLF & _
"/foo/bar/" & @CRLF & _
"/foo/bar.php" & @CRLF & _
"/foo/bar"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)