re = /((\/(index(\..+)?)?)|(\..{2,4}))$/m
str = '/foo/bar/index.php
/foo/bar/index
/foo/bar/
/foo/bar.php
/foo/bar'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result