const regex = /((\/(index(\..+)?)?)|(\..{2,4}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\\/(index(\\..+)?)?)|(\\..{2,4}))$', 'gm')
const str = `/foo/bar/index.php
/foo/bar/index
/foo/bar/
/foo/bar.php
/foo/bar`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);