import re
regex = re.compile(r"((\/(index(\..+)?)?)|(\..{2,4}))$", flags=re.MULTILINE)
test_str = ("/foo/bar/index.php\n"
"/foo/bar/index\n"
"/foo/bar/\n"
"/foo/bar.php\n"
"/foo/bar")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)