import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "tzses (.*?) www";
final String string = "# Netscape HTTP Cookie File # http://curl.haxx.se/rfc/cookie_spec.html # This file was generated by libcurl! Edit at your own risk. www.timezero.ru FALSE / FALSE 0 tzl Terminal Police www.timezero.ru FALSE / FALSE 0 tzses 10262169020539404289 www.timezero.ru FALSE / FALSE 0 tzsrv city1.timezero.ru www.timezero.ru FALSE / FALSE 0 tzlang ru\n\n\n"
+ "Это ссылка: http://www.tzpolice.ru/interface/cron/cjr.ck\n"
+ "нужно получить значение tzses\n"
+ "и записать в переменную для дальнейшей работы...\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}