using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d+\.)+\d*)";
string input = @"7-Zip (x64) 19.00.15
Acronis True Image OEM 19.0.5158
4K Video Downloader 4.19.3.4700
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}