re = /((\d+\.)+\d*)/m
str = '7-Zip (x64) 19.00.15
Acronis True Image OEM 19.0.5158
4K Video Downloader 4.19.3.4700
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end