package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\d+\.)+\d*)`)
var str = `7-Zip (x64) 19.00.15
Acronis True Image OEM 19.0.5158
4K Video Downloader 4.19.3.4700
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}