import re
regex = re.compile(r"((\d+\.)+\d*)", flags=re.MULTILINE)
test_str = ("7-Zip (x64) 19.00.15\n"
"Acronis True Image OEM 19.0.5158\n"
"4K Video Downloader 4.19.3.4700\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")