#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\()\`\bREPLACEME\b\`(?![\w\s]*[\)])"
Local $sString = "Example string: `REPLACEME` (`REPLACEME`)" & @CRLF & _
"Example string: `REPLACEME` (Something `REPLACEME` Something else)" & @CRLF & _
"Example string: `REPLACEME` (Something `REPLACEME`)" & @CRLF & _
"Example string: `REPLACEME` (`REPLACEME`Something else)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")