$re = '/(?<!\()\`\bREPLACEME\b\`(?![\w\s]*[\)])/m';
$str = 'Example string: `REPLACEME` (`REPLACEME`)
Example string: `REPLACEME` (Something `REPLACEME` Something else)
Example string: `REPLACEME` (Something `REPLACEME`)
Example string: `REPLACEME` (`REPLACEME`Something else)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);