using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\()\`\bREPLACEME\b\`(?![\w\s]*[\)])";
string input = @"Example string: `REPLACEME` (`REPLACEME`)
Example string: `REPLACEME` (Something `REPLACEME` Something else)
Example string: `REPLACEME` (Something `REPLACEME`)
Example string: `REPLACEME` (`REPLACEME`Something else)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}