const regex = /(?<!\()\`\bREPLACEME\b\`(?![\w\s]*[\)])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\()\\`\\bREPLACEME\\b\\`(?![\\w\\s]*[\\)])', 'gm')
const str = `Example string: \`REPLACEME\` (\`REPLACEME\`)
Example string: \`REPLACEME\` (Something \`REPLACEME\` Something else)
Example string: \`REPLACEME\` (Something \`REPLACEME\`)
Example string: \`REPLACEME\` (\`REPLACEME\`Something else)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}