const regex = /\/\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\d+', 'gm')
const str = `http://host.name/v2/type/44/things
http://host.name/v2/type/44
http://host.name/v2/type/30d-hot`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}