$re = '/\/\d+/m';
$str = 'http://host.name/v2/type/44/things
http://host.name/v2/type/44
http://host.name/v2/type/30d-hot';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);