#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)APDNUDES_F20[0-9]{2}_((?:[A-Za-z]+-?)*-in-(?:[A-Za-z]+-?)*)_[P|V][0-9]+(\.[\w]{3,4})?"
Local $sString = "APDNUDES_F2013_Sammi-Tye-in-Beauty_V190522172041.mp4" & @CRLF & _
"APDNUDES_F2013_Sammi-Tye-in-Classic-Curves_V190522161615.mp4" & @CRLF & _
"APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336.mp4" & @CRLF & _
"APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336" & @CRLF & _
""
Local $sSubst = "${1}${2}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)