import re
regex = re.compile(r"APDNUDES_F20[0-9]{2}_((?:[A-Za-z]+-?)*-in-(?:[A-Za-z]+-?)*)_[P|V][0-9]+(\.[\w]{3,4})?", flags=re.MULTILINE)
test_str = ("APDNUDES_F2013_Sammi-Tye-in-Beauty_V190522172041.mp4\n"
"APDNUDES_F2013_Sammi-Tye-in-Classic-Curves_V190522161615.mp4\n"
"APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336.mp4\n"
"APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336\n")
subst = "${1}${2}"
result = regex.sub(subst, test_str)
if result:
print(result)