import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^.+?(?=C700\\d*(?=\\s))";
final String string = "DFGC\n"
+ "2836 -07-0411B \n"
+ "IMUD - DHI211 (MOOYEHBF P/ \n"
+ "SHDUF) \n"
+ " C7000039694 (PD MOFIBD PODF \n"
+ "BAOJFD) ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}