use strict;
my $str = 'DFGC
2836 -07-0411B
IMUD - DHI211 (MOOYEHBF P/
SHDUF)
C7000039694 (PD MOFIBD PODF
BAOJFD) ';
my $regex = qr/(?s)^.+?(?=C700\d*(?=\s))/miup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}