re = /(?s)^.+?(?=C700\d*(?=\s))/mi
str = 'DFGC
2836 -07-0411B
IMUD - DHI211 (MOOYEHBF P/
SHDUF)
C7000039694 (PD MOFIBD PODF
BAOJFD) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end