#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\/[^\/?&#\s]+)+\/?$"
Local $sString = "api/v1" & @CRLF & _
"/api/v1" & @CRLF & _
"/api/2v1/21/" & @CRLF & _
"/api/blah/v1/" & @CRLF & _
"/api/blah blah/v1/" & @CRLF & _
"/api/ether/v1//" & @CRLF & _
"/api/23v1///" & @CRLF & _
"/api/?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")