using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\/[^\/?&#\s]+)+\/?$";
string input = @"api/v1
/api/v1
/api/2v1/21/
/api/blah/v1/
/api/blah blah/v1/
/api/ether/v1//
/api/23v1///
/api/?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}