package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\/[^\/?&#\s]+)+\/?$`)
var str = `api/v1
/api/v1
/api/2v1/21/
/api/blah/v1/
/api/blah blah/v1/
/api/ether/v1//
/api/23v1///
/api/?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}