const regex = /^(?:\/[^\/?&#\s]+)+\/?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\\/[^\\\/?&#\\s]+)+\\\/?$', 'gm')
const str = `api/v1
/api/v1
/api/2v1/21/
/api/blah/v1/
/api/blah blah/v1/
/api/ether/v1//
/api/23v1///
/api/?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}