package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^wp-content/plugins/[^/]+/`)
var str = `wp-content/plugins/event-tickets/tests/wpunit/Tribe/Tickets/Attendance_RSVP_TotalsTest.php
wp-content/plugins/the-events-calendar/tests/restv1/EventArchiveCest.php
wp-content/plugins/nodash/tests/restv1/EventArchiveCest.php
wp-content/plugins/-/tests/restv1/EventArchiveCest.php
wp-content/plugins/---/tests/restv1/EventArchiveCest.php
wp-content/plugins//tests/restv1/EventArchiveCest.php`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}