const regex = new RegExp('^wp-content/plugins/[^/]+/', 'gm')
const str = `wp-content/plugins/event-tickets/tests/wpunit/Tribe/Tickets/Attendance_RSVP_TotalsTest.php
wp-content/plugins/the-events-calendar/tests/restv1/EventArchiveCest.php
wp-content/plugins/nodash/tests/restv1/EventArchiveCest.php
wp-content/plugins/-/tests/restv1/EventArchiveCest.php
wp-content/plugins/---/tests/restv1/EventArchiveCest.php
wp-content/plugins//tests/restv1/EventArchiveCest.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}