$re = '/^wp-content/plugins/[^/]+//m';
$str = 'wp-content/plugins/event-tickets/tests/wpunit/Tribe/Tickets/Attendance_RSVP_TotalsTest.php
wp-content/plugins/the-events-calendar/tests/restv1/EventArchiveCest.php
wp-content/plugins/nodash/tests/restv1/EventArchiveCest.php
wp-content/plugins/-/tests/restv1/EventArchiveCest.php
wp-content/plugins/---/tests/restv1/EventArchiveCest.php
wp-content/plugins//tests/restv1/EventArchiveCest.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);